Log message #4141498

# At Username Text
# May 16th, 16:29 Diego_ ['validate' => false, 'checkRules' => false]
# May 16th, 16:29 jeremyharris Debug should show associations on the entity. If they're not in there, that means they didn't patch in
# May 16th, 16:29 Diego_ i have disabled the associated validation and rules
# May 16th, 16:29 Diego_ its saving only the main entity not the associated one
# May 16th, 16:28 jeremyharris Check application rules if the save isn't saving
# May 16th, 16:27 Diego_ its ok, the issue is that no errors are shown so i dont know where to search :/
# May 16th, 16:25 sdevore Sorry Diego_ not sure how to help other then to make sure you are creating the data structure correctly and try to see if anything is in the $entity->getErrors() that might help. I’ll have to pass this up the expert chain. Sorry
# May 16th, 16:23 pmoraes File uploaded https://cakesf.slack.com/files/U6X99ATG8/FAQCS4RC1/captura_de_tela_2018-05-16_a__s_13.23.10.png / https://slack-files.com/T053DPNCM-FAQCS4RC1-2e8094d094
# May 16th, 16:23 Diego_ im not using newEntity() or patchEntity(), im loading from database changing some fields and saving
# May 16th, 16:22 pmoraes when I click on it, I have 2 messages in the session
# May 16th, 16:21 sdevore I think that it it used in mass assignment done with either `newEntity()` and `patchEntity()`
# May 16th, 16:19 Diego_ arent this only for new entity?
# May 16th, 16:17 sdevore could try as a test to add `['guard'=>false]`
# May 16th, 16:17 Diego_ anyway i have tested setting it same result
# May 16th, 16:17 sdevore yea I only set specific one to true not `*` so not sure, still getting legs under me in 3.6
# May 16th, 16:16 Diego_ acording with the book it should be false: "If the * property is not defined it will default to false."
# May 16th, 16:14 Diego_ its not defined in the entity but debug shows * => true
# May 16th, 16:08 Diego_ '[accessible]' => [ '*' => true], ?
# May 16th, 16:07 sdevore Is it possible that you didn’t add the associations to the `$_accessible` property is the entity?
# May 16th, 15:54 Diego_ how can i debug a associated entity on save()?
# May 16th, 15:38 saeideng >saeideng: i will give it a try nice
# May 16th, 15:38 flavius yeah, click that 302 request then go to the sessions panel
# May 16th, 15:37 pmoraes File uploaded https://cakesf.slack.com/files/U6X99ATG8/FARQFCL6A/captura_de_tela_2018-05-16_a__s_12.36.58.png / https://slack-files.com/T053DPNCM-FARQFCL6A-d44afb98c2
# May 16th, 15:37 alexdd55 saeideng: i will give it a try
# May 16th, 15:34 pmoraes lol
# May 16th, 15:33 pmoraes no.. I'm using the bake workflow. Pretty simple. add or edit method save then redirect to index page. if the persist fail. render works otherwise no
# May 16th, 15:31 flavius @pmoraes i tested just now and it works in 3.6.2
# May 16th, 15:30 saeideng @pmoraes I tested just now and it works in 3.6.1
# May 16th, 15:30 flavius or maybe you have `<?= $this->Flash->render(); ?>` multiple times and you forgot :slightly_smiling_face:
# May 16th, 15:29 flavius if you see it in session you have a problem with displaying it, if you don't see it in there you have a problem with how you set it
# May 16th, 15:28 flavius the header should be purple to indicate your not on current request
# May 16th, 15:27 flavius File uploaded https://cakesf.slack.com/files/U75U0UMR9/FAQ6VLM1N/image.png / https://slack-files.com/T053DPNCM-FAQ6VLM1N-959b8720fa
# May 16th, 15:27 flavius File uploaded https://cakesf.slack.com/files/U75U0UMR9/FAQTBQUKU/image.png / https://slack-files.com/T053DPNCM-FAQTBQUKU-4182a6c0b0
# May 16th, 15:26 flavius debug kit history, look for the 302 request (thats the redirect), it should contain the flash in session :P
# May 16th, 15:26 saeideng @alexdd55 `this->Url->image('/images/1.jpg')` works as well
# May 16th, 15:25 neon1024 @alexdd55 Oh right, we use Imgix so we have a whole url saved in the datastore already for that :)
# May 16th, 15:25 saeideng redirect to page 1 and then page 2
# May 16th, 15:24 saeideng I guess you have 2 redirect page
# May 16th, 15:24 alexdd55 @neon1024 i need that url for my json response
# May 16th, 15:24 saeideng or see in debug_kit history
# May 16th, 15:24 saeideng and see pages request