Log message #4141566

# At Username Text
# May 16th, 18:40 phantomwatson I'd like to set up a `beforeDelete()` callback for a tree-structured table that prevents the deleting of a record if it has children. But `TreeBehavior::beforeDelete()` is invoked and deletes all of a record's children _before_ the table's `beforeDelete()` is invoked. Is my instinct right that I'd need to overload `FooTable::delete()` and put the "has children" check in _there_ to accomplish this instead of using a callback? Or make a
# May 16th, 17:04 Diego_ $saved = $this->_associations->saveParents() return true :/
# May 16th, 16:53 jeremyharris Also, you don't need the reference (and$pagamento) in the loop, and don't need the unset
# May 16th, 16:52 jeremyharris You might have to add some temporary debug statements here to figure out what's going on: https://api.cakephp.org/3.5/source-class-Cake.ORM.Table.html#1773-1838
# May 16th, 16:52 Diego_ there are a debug before save and after save
# May 16th, 16:51 jeremyharris In the paste bin you sent there are
# May 16th, 16:51 Diego_ the debug before save shows the dirty fields, debug after the save there are no dirty fields for the main entity
# May 16th, 16:50 jeremyharris Nm, has to be committed to be success
# May 16th, 16:50 Diego_ commited
# May 16th, 16:50 jeremyharris In the sql log, is the transaction rolled back or committed?
# May 16th, 16:49 jeremyharris Diego I'm confused, you said recibo saves but the entity looks dirty still
# May 16th, 16:48 pmoraes my controller and views are baked FYI lol
# May 16th, 16:48 pmoraes yes I have
# May 16th, 16:48 Diego_ https://pastebin.com/RZ7nyQNs
# May 16th, 16:47 flavius you have the same structure like me, Flash -> flash -> 0
# May 16th, 16:47 pmoraes really strange my issue
# May 16th, 16:47 pmoraes lol
# May 16th, 16:47 pmoraes I'm setting up a new project to test it
# May 16th, 16:47 pmoraes I already did too
# May 16th, 16:46 pmoraes yes
# May 16th, 16:46 flavius debug there
# May 16th, 16:46 pmoraes when it redirect, It seems it lost the flash key. Then I just have Flash.0 instead of Flash.flash.0
# May 16th, 16:46 flavius https://github.com/cakephp/cakephp/blob/master/src/View/Helper/FlashHelper.php
# May 16th, 16:46 pmoraes there I see a strange thing
# May 16th, 16:45 pmoraes the core
# May 16th, 16:45 pmoraes yesterday I was debugging
# May 16th, 16:45 flavius beats me :slightly_smiling_face:
# May 16th, 16:45 pmoraes exactly
# May 16th, 16:45 flavius its just not displaying for some strange reason
# May 16th, 16:45 jeremyharris Ok after the success then
# May 16th, 16:45 pmoraes yes*
# May 16th, 16:45 pmoraes ues
# May 16th, 16:45 Diego_ it never go to the else part of save because there are no erros
# May 16th, 16:45 flavius well the session is there, you saw it in debug kit
# May 16th, 16:45 pmoraes if my form fail in the add view. it shows the message
# May 16th, 16:44 pmoraes just not working when I use redirect
# May 16th, 16:44 pmoraes the most strange is. Its working when I render the same view
# May 16th, 16:44 pmoraes I already did it.
# May 16th, 16:44 flavius maybe you have it twice? search your project for Flash->render(
# May 16th, 16:44 pmoraes File uploaded https://cakesf.slack.com/files/U6X99ATG8/FAS17D18X/captura_de_tela_2018-05-16_a__s_13.43.44.png / https://slack-files.com/T053DPNCM-FAS17D18X-d3fcec48e6
# May 16th, 16:44 flavius i have no clue then :slightly_smiling_face: