Log message #4190186

# At Username Text
# Jun 19th, 15:52 bravo-kernel @olanowsubomi it seems you are a novice in this area, cakebox will be your best choice, everything is tailored to cakephp
# Jun 19th, 15:51 olanowsubomi it even not possible to install xammp on window 32 bit
# Jun 19th, 15:51 bravo-kernel after that... everything will make sense
# Jun 19th, 15:51 bravo-kernel it contains a simple instruction for creating your first website (using cakephp)
# Jun 19th, 15:51 bravo-kernel ?
# Jun 19th, 15:50 bravo-kernel @olanowsubomi did you read the intro on https://github.com/alt3/cakebox
# Jun 19th, 15:49 olanowsubomi ?
# Jun 19th, 15:49 olanowsubomi but can you use cakephp code in vagrant
# Jun 19th, 15:48 olanowsubomi i dont know what a powershell is
# Jun 19th, 15:48 olanowsubomi im typing it into a command window
# Jun 19th, 15:46 olanowsubomi ok, let me ask some questions
# Jun 19th, 15:45 neon1024 See the big grey box about Windows 32 bit
# Jun 19th, 15:45 neon1024 The error with the SSL module is detailed in the PHP manual here https://www.php.net/manual/en/openssl.installation.php
# Jun 19th, 15:44 neon1024 XAMPP is just a nice installer, which will install and configure webserver, php and some other bits for you
# Jun 19th, 15:44 neon1024 As it will allow you to virtualise a Linux computer for you to work in
# Jun 19th, 15:44 neon1024 The reason people were suggesting that you use a Vagrant virtual machine to develop your application is to sidestep many of the issues with developing in Windows
# Jun 19th, 15:43 neon1024 Also, are you typing your composer commands into a command window or powershell?
# Jun 19th, 15:42 neon1024 Is this a development machine or a production server?
# Jun 19th, 15:42 olanowsubomi ?
# Jun 19th, 15:42 olanowsubomi or you have never tried downloading this on window32 bit
# Jun 19th, 15:40 olanowsubomi or what do u suggest i do?
# Jun 19th, 15:39 olanowsubomi or how do i enabled it?
# Jun 19th, 15:38 olanowsubomi i tried remove ';' before it as sugested by someone to no avail
# Jun 19th, 15:37 graziel sounds like composer cant use ssl cause openssl extension in your php.ini isnt enabled/installed
# Jun 19th, 15:37 olanowsubomi somebody later suggest i use vagrant in place of wampp server i dont even understand
# Jun 19th, 15:35 olanowsubomi this is the message i sent to someone earlier
# Jun 19th, 15:34 slackebot1 the ';' before both extension=mbstring and extension=intl in both php.ini files for those extensions to work for cakephp downloading. i would appreciate it if my message is being considered and responded to in good time. Thanks for your patience. .
# Jun 19th, 15:34 slackebot1 required for SSL/TLC protection but is not available if you can not enable the open ssl extension; you can disable this error, at your own risk, by setting the disable 'disable-tls' option to true. ...' please i dont understand what all this above means but i have attached a copy of both my php.ini development and production file for you to see, though i have made some earlier adjustment to it based on the information i got that i would need to remove
# Jun 19th, 15:34 olanowsubomi ok. see this,Hi, please can you do a code review and send me an email at olanowsubomi@gmail.com, i am having issue to download cakephp on window 7 32bit let me explain to you that i have successfully downloaded the composer but by typing this ' composer create-project --prefer-dist cakephp/app my_app_name' into it to download cakephp, it is bringing this below: '... [ Composer\Exception\NoSs1Exception] The open ssl extension is
# Jun 19th, 15:34 neon1024 Yes, please can you share the error message with us using a code block in Slack?
# Jun 19th, 15:33 graziel what message
# Jun 19th, 15:32 olanowsubomi i have been trying to intall cakephp with a error message appearing?
# Jun 19th, 15:31 olanowsubomi ok, i will tell you
# Jun 19th, 15:31 graziel why would you not want to use composer, its great
# Jun 19th, 15:31 neon1024 @olanowsubomi What is it that you’re trying to achieve?
# Jun 19th, 15:30 olanowsubomi do you mean i would be able to access cakephp and use it for project without using compoer?
# Jun 19th, 15:30 neon1024 @olanowsubomi Not me, I don’t use Vagrant :slightly_smiling_face:
# Jun 19th, 15:27 ricksaccous yeah you could use that one as well
# Jun 19th, 15:27 graziel there is also https://github.com/alt3/cakebox
# Jun 19th, 15:27 olanowsubomi hello, are you still around?
# Jun 19th, 15:26 ricksaccous read the instructions