Log message #4217054

# At Username Text
# Dec 2nd, 17:12 dereuromark after that I was basically not able to further assist
# Dec 2nd, 17:12 dereuromark my previous answer was only to the prefix part
# Dec 2nd, 17:12 dereuromark not offended, but disturbed for no reason. You shouldnt tag someone specific unless they actually are part of the conversation already.
# Dec 2nd, 17:10 noel oh ok. Sorry if I offended, may I ask why?
# Dec 2nd, 17:09 neon1024 Guess that it is pretty recent, perhaps they’ll spin up some boxes soon
# Dec 2nd, 17:07 neon1024 :face_palm:
# Dec 2nd, 17:07 dereuromark @neon1024 i tried, and travis doesnt support it yet
# Dec 2nd, 17:07 dereuromark @noel you shouldnt tag me here
# Dec 2nd, 17:07 neon1024 Can’t what?
# Dec 2nd, 17:06 dereuromark @neon1024 you cannot
# Dec 2nd, 17:04 slackebot is included in the JSON as well.
# Dec 2nd, 17:04 noel @ndm @dereuromark there's a relationship on the entity but it seems to be not seeing it somehow. The JSON object that is being processed by the `->getRepository` call is being written with a hyphen instead of an underscore. E.g. ```{ ... "enquiry-type": null }, "enquiry-type"``` ... but I don't understand why. There is a belongsTo relationship between `enquiry` and `enquiry_type` tables via the `enquiry_type_id` ; the value for which which
# Dec 2nd, 17:02 neon1024 Although it is a snapshot, could probably set 7.4.0 for that now in the travis.yml
# Dec 2nd, 17:01 slackebot <neon1024>
# Dec 2nd, 17:01 neon1024 Doesn’t run on 7.4
# Dec 2nd, 17:00 neon1024 @cakebot travis is https://travis-ci.org/cakephp
# Dec 2nd, 17:00 slackebot !travis
# Dec 2nd, 16:59 slackebot Command sent from Slack by neon1024:
# Dec 2nd, 16:54 dereuromark looking into the travis file per build would have easily told u
# Dec 2nd, 16:54 dereuromark 2.x, 3.x and 4.x
# Dec 2nd, 16:53 alexmax Does 3.8 support it?
# Dec 2nd, 16:53 alexmax PHP 7.4 came out a few days ago
# Dec 2nd, 16:44 lucas.iturbide alright.. it came back to life
# Dec 2nd, 16:33 lucas.iturbide Hi, is it me or the website https://cakephp.org/ is not loading with the error `ERR_SSL_VERSION_OR_CIPHER_MISMATCH` ?
# Dec 2nd, 16:06 devito @ricksaccous its only 1 deep and its ahas one relationship and for some reason the validation rules arent being triggered on the profile. But if i move the validators to the user model and add nested its fine.
# Dec 2nd, 16:02 neon1024 https://book.cakephp.org/3/en/orm/saving-data.html#converting-request-data-into-entities
# Dec 2nd, 16:01 neon1024 Other ones you specify with the ‘associated’ key in the options array of `patchEntity`
# Dec 2nd, 16:01 neon1024 1st level associations will be saved automatically iirc
# Dec 2nd, 16:00 david but I can't see the way
# Dec 2nd, 16:00 david I am trying to save an additional field in the relationship table
# Dec 2nd, 15:59 ricksaccous also depends how the data is being set i think, meh
# Dec 2nd, 15:59 ricksaccous might have to cascadeCallbacks
# Dec 2nd, 15:58 david is there a way to trigger the "beforeMarshal" in the RelationShipTable.php of a belongstomany relationship?
# Dec 2nd, 15:48 ricksaccous i think if it's too deep it won't unless you specify
# Dec 2nd, 15:48 ricksaccous depending on the nature of the relationship
# Dec 2nd, 15:48 ricksaccous if you don't put any validation options in by default it will
# Dec 2nd, 15:46 devito like if i do patch entity on a user and pass in data for the profile as well
# Dec 2nd, 15:46 devito when creating a new entity that has associations, will the associated data be validated or just the primary entity that was instanciated?
# Dec 2nd, 15:44 neon1024 It’s fine to ask questions, but it’s also worth have a read of the documentation first :thumbsup:
# Dec 2nd, 15:43 gianmarxgagliardi I didn't want to take advantage of your availability or community
# Dec 2nd, 15:42 gianmarxgagliardi sorry @neon1024