Log message #4214258

# At Username Text
# Nov 20th, 10:03 challgren I have a feeling if I upgrade my major app its going to require me to update a bunch of plugins
# Nov 20th, 10:00 neon1024 I’ll try and find some time to build a new app with the 4.0.0-RC1 I think
# Nov 20th, 09:57 neon1024 Does the 4.x branch of `cakephp/upgrade` work okay now?
# Nov 20th, 09:48 dereuromark my old one had a "skeleton" command, that might be missing in the core one still.
# Nov 20th, 09:48 dereuromark no pulling IMO, the upgrade tooling ideally should at some point provide all necessities
# Nov 20th, 09:46 challgren new branch, pull cakephp/app? run composer update, run upgrade tooling?
# Nov 20th, 09:45 dereuromark a new branch and some of the upgrade tooling run should usually suffice.
# Nov 20th, 09:45 neon1024 I probably won’t port my apps to 4.x until a few releases
# Nov 20th, 09:44 challgren Might hold off on 4.x
# Nov 20th, 09:44 challgren Yeah Im thinking the best route
# Nov 20th, 09:43 neon1024 I guess you could make a new branch and move all your templates around and all that stuff
# Nov 20th, 09:41 neon1024 > We would greatly appreciate it if you temporarily upgraded your application, and ran your tests
# Nov 20th, 09:41 neon1024 Seems so, which runs contrary to the release notes
# Nov 20th, 09:41 challgren So vibe I’m getting is if your upgrading to 4.x its best to use a new skeleton
# Nov 20th, 09:07 jotpe Morning
# Nov 20th, 08:40 neon1024 Morning all
# Nov 20th, 06:35 conehead @brian.french ```<?xml version="1.0"?> <ruleset name="Custom Standard"> <rule ref="PSR12"/> </ruleset>`#```
# Nov 20th, 00:49 dereuromark sure, just reference it there.
# Nov 20th, 00:43 brian.french @dereuromark Codesniff question. Do you know if there is a way to import/extend a ruleset into your own local ruleset.xml? googlefooing isn't producing any answers.
# Nov 19th, 17:49 jotpe Hm okay, so thanks @admad. Maybe I'll try upgrading/testing later then.
# Nov 19th, 17:46 jotpe _Since this skeleton is a starting point for your application and various files would have been modified as per your needs, there isn't a way to provide automated upgrades, so you have to do any updates manually._ :face_with_rolling_eyes:
# Nov 19th, 17:44 admad best create a new app if you want to try 4 https://github.com/cakephp/app/tree/4.x
# Nov 19th, 17:43 admad simply bumping up core for existing 3.x app skeleton isnt going to work anyway
# Nov 19th, 17:43 jotpe should I change to ^4.0 and then composer update?
# Nov 19th, 17:42 jotpe 3.8.*
# Nov 19th, 17:42 admad what's the current cake version in you composer.json?
# Nov 19th, 17:36 jotpe @admad Did `composer update` and then `composer require --update-with-dependencies "cakephp/cakephp:4.0.0-RC1"` with the same results. Or should I change the version in my composer.json?
# Nov 19th, 17:32 admad just do `composer update`
# Nov 19th, 17:30 jotpe I did `composer require --update-with-dependencies "cakephp/cakephp:4.0.0-RC1"`
# Nov 19th, 17:29 slackebot <jotpe>
# Nov 19th, 17:29 jotpe I tried to upgrade to 4x. RC1 and got this composer message:
# Nov 19th, 16:54 savant IRC test message
# Nov 19th, 16:54 savant slack test message
# Nov 19th, 16:22 neon1024 Bake, Crud and CrudView will get most of it done
# Nov 19th, 16:22 noel (Still looking for the `->writeAppForMe` method)
# Nov 19th, 16:04 neon1024 Worth noting if you’re using `resources()` and you haven’t implemented the methods, the routes will throw missing method errors
# Nov 19th, 16:02 neon1024 Outside of this table, you’ll need to create your own routing
# Nov 19th, 16:02 neon1024 See the table :point_right: https://book.cakephp.org/3/en/development/routing.html#restful-routing
# Nov 19th, 16:01 noel I'm using Accept and Content Headers instead of .json ext
# Nov 19th, 16:01 neon1024 The `resources()` method only maps certain things
# Nov 19th, 16:01 noel via Postman