Log message #4198485

# At Username Text
# Aug 15th, 23:11 dereuromark see geo plugin, it uses the same thing
# Aug 15th, 23:10 jslamka5685 How do I go about including a virtual field within a pagination query?
# Aug 15th, 20:13 latenal @admad, it worked! Thanks
# Aug 15th, 20:11 admad same for `Date`
# Aug 15th, 20:11 admad @latenal add `FrozenDate::setJsonEncodeFormat('yyyy-MM-dd')` in bootstrap
# Aug 15th, 20:04 latenal yes
# Aug 15th, 20:03 ricksaccous are you using _serialize?
# Aug 15th, 20:01 latenal Hi, how do I change date format in a json output? I have `index` method that returns dates like this “2019-08-15T00:00:00+00:00”. I would like to remove the time part (in the database this field is DATE not DATETIME)
# Aug 15th, 18:52 jotpe thanks
# Aug 15th, 18:52 jotpe :shuffleparrot:drives me crazy
# Aug 15th, 18:50 ricksaccous it's not using the actual roles table class when you do that though
# Aug 15th, 18:50 challgren did you try find()->where([])->contain()
# Aug 15th, 18:50 ricksaccous yeah because it uses magic
# Aug 15th, 18:50 jotpe o.O
# Aug 15th, 18:50 jotpe Without the contain the find is working without plugin prefix
# Aug 15th, 18:49 ricksaccous oh yeah lol
# Aug 15th, 18:49 ndm I never liked these magic tables
# Aug 15th, 18:49 jotpe Ty :slightly_smiling_face:
# Aug 15th, 18:48 jotpe I know it's gonna hurt @ndm
# Aug 15th, 18:46 ndm @jotpe `->get('Users.Users')`
# Aug 15th, 18:44 jotpe got the same error @ricksaccous
# Aug 15th, 18:43 mrfeedback how to handle massassignments with Authorization plugin? `$collectionparts = $this->Collectionparts->patchEntities($collectionparts,$data); $this->Authorization->can($collectionparts,'update'); ` throws an error ` Error: [Authorization\Policy\Exception\MissingPolicyException] Policy for 'array' has not been defined.`
# Aug 15th, 18:43 slackebot <jotpe>
# Aug 15th, 18:43 slackebot <jotpe>
# Aug 15th, 18:37 jotpe So with a through model you mean create the mdel classes for roles_users?
# Aug 15th, 18:34 ricksaccous and creating that middle man model
# Aug 15th, 18:34 ricksaccous i always like using the through or whatever the option is called though
# Aug 15th, 18:33 ricksaccous so that's why i wanted to see if there's something wrong in your association config there that's breaking things
# Aug 15th, 18:33 ricksaccous it will just assume the join table, and you're following conventions
# Aug 15th, 18:33 jotpe actually it#s a bit strange. it uses mostly the same config as the CMS tutorial: https://book.cakephp.org/3.0/en/quickstart.html#cms-tutorial-creating-the-database
# Aug 15th, 18:32 jotpe just the classname shouldn't work...it uses the join table
# Aug 15th, 18:30 ricksaccous if that doesn't work then maybe create a through model and use the through option as well
# Aug 15th, 18:29 ricksaccous wait a minute
# Aug 15th, 18:29 ricksaccous other configs...
# Aug 15th, 18:29 ricksaccous does it work?
# Aug 15th, 18:29 ricksaccous if you try it with just className defined and take out the other ones from the association config
# Aug 15th, 18:26 jotpe It's in the samee plugin called Users
# Aug 15th, 18:26 challgren Are you using a plugin for your Roles?
# Aug 15th, 18:26 jotpe `$this->belongsToMany('Roles', [ 'foreignKey' => 'user_id', 'targetForeignKey' => 'role_id', 'joinTable' => 'roles_users', 'className' => 'Users.Roles' ]);`
# Aug 15th, 18:26 jotpe My UsersTable has this association:
# Aug 15th, 18:25 jotpe I know, it's a silly question, but i don't get the error. I have 3 tables (users, roles and roles_users). roles_users as a join table contains user_id/role_id which has fk to the corresponding table. When i do: `$usersTable = TableRegistry::getTableLocator()->get('Users'); $users = $usersTable->find('all', ['contain' => ['Roles']]);` I get _The Roles association is not defined on Users._