Log message #4116837

# At Username Text
# Feb 13th, 14:44 neon1024 The one I remember was like this, https://github.com/cakephp/app/blob/master/config/app.default.php#L258
# Feb 13th, 14:44 neon1024 I’d read that issue, but didn’t see a solution
# Feb 13th, 14:44 neon1024 Oh, thanks @saeideng
# Feb 13th, 14:43 neon1024 Found it, https://stackoverflow.com/a/36033983/234451
# Feb 13th, 14:40 saeideng https://github.com/cakephp/cakephp/issues/10723
# Feb 13th, 14:40 saeideng neon1024
# Feb 13th, 14:39 loginews I have used $this->assign('title','mytitle') near the top of several ctp files. It works. But in one index.ctp file, mytitle is appended to Cakephp: the rapid development framework... What could have gone wrong ?
# Feb 13th, 14:27 rmilldes No worries.. This is truly a test user table that I created by hand in MySQL, baked it and now am stepping through adding authentication.
# Feb 13th, 14:24 neon1024 Apologies for being lazy, but can someone remind me the database config for disabling the correct group by? `sql_mode=only_full_group_by`
# Feb 13th, 14:23 admad rmilldes: "When I edit an existing user with a plaintext password" why is existing password in plain text in the first place? :slightly_smiling_face: I presume you are upgrading an old system. Such a problem would not occur when password is already properly hashed. In your case forcing password field to be dirty is the easiest option
# Feb 13th, 14:17 dereuromark using the same value for hashed and nonhashed is a code smell IMO. too many things that then can go wrong.
# Feb 13th, 14:17 dereuromark super old example, the id shouldnt be in there anymore, 2.x relict
# Feb 13th, 14:17 rmilldes In this specific case, it was because they were previously plaintext and the intent was to hash them but I can see the point in not querying if not dirty but it is always nice to know how things work behind the scenes. dereuromark: Thanks, I will check that out.
# Feb 13th, 14:15 dereuromark rmilldes: so many struggle with it always, but its actually rather easy if you e.g. use https://github.com/dereuromark/cakephp-sandbox/blob/3.0/src/Controller/AccountController.php#L237-L242 3 lines of code, nothing in entity or model. but find your own approach that works for you.
# Feb 13th, 14:15 admad *but why
# Feb 13th, 14:15 admad but bother if nothing has changed?
# Feb 13th, 14:14 neon1024 Or you could manually set the fields as dirty if you wanted to
# Feb 13th, 14:14 rmilldes How/where would I do so? I'm just getting my feet wet in Cake.
# Feb 13th, 14:09 dereuromark rmilldes: I recommend using aliases here for the fields, to avoid this.
# Feb 13th, 14:09 admad np
# Feb 13th, 14:09 rmilldes Thanks!
# Feb 13th, 14:08 rmilldes Ahh, OK... It was driving me crazy for a good while
# Feb 13th, 14:08 admad yes the ORM won't make any DB query if none of the entity fields are dirty.
# Feb 13th, 14:07 rmilldes The reason I ask is that in an app similar to the tutorials, when I add a user, the password hashes. When I edit an existing user with a plaintext password, it will not hash via edit unless I change it to something else first. If I submit or re-enter the existing plaintext password, _setPassword() is never called. If I alter it, _setPassword is called from the edit page.
# Feb 13th, 14:05 rmilldes Hello all... I have a general question regarding the edit functionality generated by bake in v. 3.5. Is it normal behavior to not process the submit from the edit form if none of the fields have been altered?
# Feb 13th, 13:59 hmic :P
# Feb 13th, 13:51 jameg83 I’ll follow this step and report back. I’m away from my machine atm,
# Feb 13th, 13:49 hmic what happens?
# Feb 13th, 13:49 hmic and call wkhtmltopdf from the commandline on that file to generate a pdf manually - keep the php dev server running during the step!
# Feb 13th, 13:48 hmic ok. lets save that page from your browser
# Feb 13th, 13:48 jameg83 Yes it shows as html..
# Feb 13th, 13:42 hmic does your browser show it?
# Feb 13th, 13:42 hmic lets try another thing: render that tempalte as html, not pdf
# Feb 13th, 13:40 jameg83 If I navigate to http://localhost:8765/pathtolocalfile.jpg in my browser it loads fine. It’s when It’s in my template.
# Feb 13th, 13:37 hmic of if you reference that path in the template to create a pdf?
# Feb 13th, 13:37 hmic jameg83: if you open that url in your browser, the pathtolocalfile.jpg, it hangss?
# Feb 13th, 13:00 jameg83 I suspected permissions. Everything is read access as a minimum apart from my root folder which is 750, but I think that’s standard.
# Feb 13th, 12:59 ahmed_bodi However the page is in french instead of english
# Feb 13th, 12:59 ahmed_bodi @admad last remaining thing. On login, The site is set to the appropriate language, all the links work. However, on login im using Auth->redirectURL() and it redirects me to /en instead of /fr
# Feb 13th, 12:57 ahmed_bodi @jameg83 permissions?
# Feb 13th, 12:51 admad IDK