Log message #4116805

# At Username Text
# Feb 13th, 13:42 hmic lets try another thing: render that tempalte as html, not pdf
# Feb 13th, 13:40 jameg83 If I navigate to http://localhost:8765/pathtolocalfile.jpg in my browser it loads fine. It’s when It’s in my template.
# Feb 13th, 13:37 hmic of if you reference that path in the template to create a pdf?
# Feb 13th, 13:37 hmic jameg83: if you open that url in your browser, the pathtolocalfile.jpg, it hangss?
# Feb 13th, 13:00 jameg83 I suspected permissions. Everything is read access as a minimum apart from my root folder which is 750, but I think that’s standard.
# Feb 13th, 12:59 ahmed_bodi However the page is in french instead of english
# Feb 13th, 12:59 ahmed_bodi @admad last remaining thing. On login, The site is set to the appropriate language, all the links work. However, on login im using Auth->redirectURL() and it redirects me to /en instead of /fr
# Feb 13th, 12:57 ahmed_bodi @jameg83 permissions?
# Feb 13th, 12:51 admad IDK
# Feb 13th, 12:48 jameg83 I’m using absolute paths bwt.
# Feb 13th, 12:47 jameg83 @admad Hi, are there any known issues with using the cake dev server with cakepdf. I’ve finally got cakepdf set up with wkhtmltopdf but my assets won’t load locally. I can pull any image off the web within my template file and it works fine, I.e (http://arandomfileurl.jpg) but (http://localhost:8765/pathtolocalfile.jpg) causes my browser to hang. Thanks.
# Feb 13th, 12:32 ahmed_bodi @admad cheers dude! that was it, I accidentally put the key into the wrong array
# Feb 13th, 12:31 ahmed_bodi hmmm one sec
# Feb 13th, 12:30 ahmed_bodi yep
# Feb 13th, 12:30 admad did you set `'I18n.languages' config as shown in readme?
# Feb 13th, 12:30 ahmed_bodi i'm getting about/faqs?lang=en
# Feb 13th, 12:30 ahmed_bodi i've been using the debug kit to do it. Ive changed it. Still no luck yet @admad
# Feb 13th, 12:28 admad also you can use `bin/cake routes` to check the routes connected
# Feb 13th, 12:25 ahmed_bodi ok let me try that
# Feb 13th, 12:25 ahmed_bodi ah
# Feb 13th, 12:25 admad https://github.com/admad/cakephp-i18n#i18nroute
# Feb 13th, 12:25 admad you don't need to add the `/:lang` part when using my I18nRoute class
# Feb 13th, 12:23 ahmed_bodi and thats how ive produced it
# Feb 13th, 12:23 ahmed_bodi <li><?= $this->Html->link('<i class="fa fa-files-o"></i><span>Login</span>', ['controller' => 'Profile', 'action' => 'login', 'lang' => $lang], array('escape' => false)); ?></li>
# Feb 13th, 12:23 ahmed_bodi http://exchange.vapesquaddirect.co.uk/profile/login?lang=en
# Feb 13th, 12:23 ahmed_bodi with those routes im getting this for the link
# Feb 13th, 12:20 ahmed_bodi https://gist.github.com/ahmedbodi/08f2e153b52d66e4e18372ea3a12e89f
# Feb 13th, 12:20 ahmed_bodi @admad they are
# Feb 13th, 12:19 ahmed_bodi I'm using prefixed controllers for things like the admin area
# Feb 13th, 12:18 admad ahmed_bodi: make sure your routes with /:lang are connected before other routes
# Feb 13th, 12:15 neon1024 I’m not too sure why you include a `*` at the end of your route though. Do you have routing token with slashes in them?
# Feb 13th, 12:15 neon1024 Although my first thought would be to use a prefix, but you probably don’t want prefixed controllers and such, so not a great idea
# Feb 13th, 12:14 neon1024 `$routes->connect('/:lang/:controller/:action', ['lang' => '[\w]+']);` perhaps
# Feb 13th, 12:14 neon1024 All I can think of is specifying the pattern for the token in the routing
# Feb 13th, 12:04 ahmed_bodi however instead it gives /profile/login?lang=en
# Feb 13th, 12:04 ahmed_bodi i figured doing Html->link(['controller' => 'Users', 'action' => 'login', 'lang' => $lang]) should work
# Feb 13th, 12:04 ahmed_bodi since the structure of the routes is /:lang/:controller/:action*
# Feb 13th, 12:03 ahmed_bodi @hmic, got that cleared, not sure what it was. But i'm not sure how to make the Html Helper use the language in the URL's
# Feb 13th, 11:46 hmic clear cache
# Feb 13th, 11:43 ahmed_bodi i've used I18n:setLocale to set the locale and things like the dates are converted fine. Just the text isnt converted
# Feb 13th, 11:42 ahmed_bodi Hi guys, I'm having an issue with cakephp. It doesnt appear to be loading the language .po files when i try and use the translate